Homework 1 forum

Permission problem when running the CI on gitlab

 
Avatar Reka Inovan
Permission problem when running the CI on gitlab
par Reka Inovan, vendredi, 16 octobre 2020, 17:10
 

Hello,

I am having some trouble when running the CI on gitlab. The log says the following,

=== RUN   TestBinGossiper_Scenario
    bingossip_test.go:443: 
        	Error Trace:	bingossip_test.go:443
        	            				bingossip_test.go:22
        	Error:      	Received unexpected error:
        	            	failed to start binary:
        	            	    go.dedis.ch/cs438/hw1/gossip.Factory.New
        	            	        /builds/cs438/students/cs438-hw1-student-inovan/gossip/bingossip.go:113
        	            	  - failed to run node:
        	            	    go.dedis.ch/cs438/hw1/gossip.(*BinGossiper).startBinGossip
        	            	        /builds/cs438/students/cs438-hw1-student-inovan/gossip/bingossip.go:613
        	            	  - fork/exec ./hw1.linux.amd64: permission denied
        	Test:       	TestBinGossiper_Scenario
--- FAIL: TestBinGossiper_Scenario (0.00s)
It seems the CI fails to run the binary hw1.linux.amd64 due to some permission mistake. I have no problem when I run the tests on my computer. Just to be clear it also fails for other TestBinGossiper cases, not only for TestBinGossiper_Scenario.

I wonder if other students also experience this problem, or if I need to setup the permission somewhere.

Avatar Peter Krcmar
Re: Permission problem when running the CI on gitlab
par Peter Krcmar, vendredi, 16 octobre 2020, 17:34
Avatar Reka Inovan
Re: Permission problem when running the CI on gitlab
par Reka Inovan, vendredi, 16 octobre 2020, 17:47
 

This is exactly what I needed. Thanks Peter.